Página 2 de 2 PrimerPrimer 12
Resultados 11 al 19 de 19
  1. #11
    Jovencit@ en el foro
    Avatar de Raven

    Fecha de Ingreso
    14/jul/2017
    Mensajes
    13
    Lector
    Kobo

    Re: Ayuda instalación Koreader

    Cita Iniciado por danielr Ver Mensaje
    Puse los mismos 3 archivos del diccionario que si funciona en Cool Reader en la carpeta de mencion: data/dict. En el caso del Korereader no funcionan. Después he leído que el problema es que el formato de "stardict" es más moderno del que lee Korereader. ¿Tendrás algún diccionario stardict 2.4 para pasarme que esa versión parece ser la que funciona? Desde ya muchas gracias.
    Eso probablemente te ocurra porque uses una versión de koreader antigua. Desde Julio-2016 soporta los diccionarios con formato stardict 3.0
    Osea que antes de nada probaría ese diccionario en una de las últimas versiones de: http://build.koreader.rocks/download/nightly/ , como por ejemplo: http://build.koreader.rocks/download...8-g3c99600.zip
    Además a mayores ganas que esta versión te guarda el historial de las palabras buscadas:

  2. El Siguiente Usuario Agradeció a Raven Por Este Mensaje:


  3. #12
    Jovencit@ en el foro
    Avatar de Raven

    Fecha de Ingreso
    14/jul/2017
    Mensajes
    13
    Lector
    Kobo

    Re: Ayuda instalación Koreader

    Este mensaje viene de: http://www.lectoreselectronicos.com/...834#post247834

    Me autocito porque lo que os ocurre se soluciona de la siguiente forma:
    Cita Iniciado por Raven Ver Mensaje
    Vaya, como me diste las gracias en el otro mensaje creí que lo habrías solucionado... En fin, prueba desmarcando (en el menú de koreader "pulsa" en el icono que es una "lupa" ---> "Configurar diccionarios" --> "Diccionarios instalados") todos los diccionarios que tengas instalados. Y haz la consulta consecuente en el texto a ver si ahora te funciona.
    Esto debe ser un bug porque es algo ilógico o "contra-intuitivo". Con las todas las "marquitas" puestas señalando que todos los diccionarios están activos, pues resulta que no funcionan. Es lo que os sucede.
    (Daniel por un momento me hiciste dudar, llegue a pensar que el problema al que te referías igual eran las inflexiones de determinadas palabras, pero viendo que haces búsquedas como esas, y además con eses diccionarios que el programa te detecta correctamente, no creo que tengas problemas haciendo lo que te pongo a continuación.)

    La solución es la que comente previamente: Desmarcarlas todas (si sólo hay una [sólo un diccionario], pues ya estaría), y probar. A mi me funcionan pues como 10 diccionarios distintos a la vez. Luego puedes elegir que diccionarios quieres activar eligiendo la "marquita"-"casilla" correspondiente.
    Por cierto, no conviene tener "tropecientos" diccionarios activos a la vez porque a más diccionarios activos, más tiempo tarda el programa en mostrar las búsquedas (y por extensión más batería gasta haciendo algo inútil).

    Edito para añadir capturas de pantalla:
    Archivo Adjunto 12611Archivo Adjunto 12612
    He añadido unos cuantos diccionarios de la web de surquizu. Como veis en esa búsqueda para la palabra "lúcido" muestra los resultados de 5 diccionarios distintos (de 10-20 posibles y activos).
    Y aquí en caso de que limites el número de diccionarios activos:
    Archivo Adjunto 12613Archivo Adjunto 12614
    Para la palabra "torpor" se muestran sólo los resultados de los 2 diccionarios que he activado.

  4. El Siguiente Usuario Agradeció a Raven Por Este Mensaje:


  5. #13
    Jovencit@ en el foro
    Avatar de Raven

    Fecha de Ingreso
    14/jul/2017
    Mensajes
    13
    Lector
    Kobo

    Re: Ayuda instalación Koreader

    Cuando se usa un firmware >= 4.6.9990 existe un bug conocido que hace que la parte de koreader que "maneja" los diccionarios no funcione. Para comprobarlo, cuando veis que koreader no arroja resultados, tenéis que mirar un archivo de texto llamado "crash.log" que esta dentro de la carpeta de koreader. Si aparecen las lineas "Segmentation fault" significa que probablemente estéis afectados por el bug y entonces como solución deberéis actualizar a la siguiente versión: http://build.koreader.rocks/download...3-g3639c3e.zip

    Más info: https://github.com/koreader/koreader/issues/3302

  6. #14
    Veteran@ en el foro
    Avatar de surquizu

    Fecha de Ingreso
    05/jun/2008
    Ubicación
    Zaragoza
    Mensajes
    3.913
    Sexo
    Sexo usuari@
    Lector
    PRS-505, kobo AuraHD. kobo AuraH2O, kobo GloHD, kobo aura ONE

    Re: Ayuda instalación Koreader

    Cita Iniciado por Raven Ver Mensaje
    Cuando se usa un firmware >= 4.6.9990 existe un bug conocido que hace que la parte de koreader que "maneja" los diccionarios no funcione. Para comprobarlo, cuando veis que koreader no arroja resultados, tenéis que mirar un archivo de texto llamado "crash.log" que esta dentro de la carpeta de koreader. Si aparecen las lineas "Segmentation fault" significa que probablemente estéis afectados por el bug y entonces como solución deberéis actualizar a la siguiente versión: http://build.koreader.rocks/download...3-g3639c3e.zip

    Más info: https://github.com/koreader/koreader/issues/3302

    Nada... actualizada la versión y sigue el "segmentation fault". No funcionan los diccionarios. Raven, a ti que te funciona ¿como tienes instalado el KOReader? con KSM o con fmon?

  7. #15
    Jovencit@ en el foro
    Avatar de Raven

    Fecha de Ingreso
    14/jul/2017
    Mensajes
    13
    Lector
    Kobo

    Re: Ayuda instalación Koreader

    Cita Iniciado por surquizu Ver Mensaje
    Nada... actualizada la versión y sigue el "segmentation fault". No funcionan los diccionarios. Raven, a ti que te funciona ¿como tienes instalado el KOReader? con KSM o con fmon?
    En mi caso particular estoy con un firmware 3.X y KSM. No uso "nickel" para nada entonces a mi no me renta actualizar el firmware...

    Mmm, si miras el hilo al que hice referencia, existen reportes positivos con el firmware >= 4.6.9990 y KSM. No hay nadie que explícitamente diga que le funciona usando fmon, lo cual no quiere decir que alguno de ellos no lo este usando o que esa combinación de firmware+koreader_parcheado+fmon no lo haga. Pero a ti no te funciona, luego es probable que haya todavía un problema no resuelto que habría que reportar...
    Pero bueno antes de nada y a pesar de que en teoría desde hace unos días todas las versiones que se generan automáticamente diariamente (nightly's) ya vienen parcheadas, podrías probar con las versiones parcheadas del binario "sdcv" que proporciona Frenzie en el hilo, y ver si te funciona koreader con una de ellas. Sería sustituir el binario que tengas en el lector por uno de estos...:
    1)https://github.com/koreader/koreader...x-gnuabihf.zip
    2)https://github.com/koreader/koreader...2017-10-18.zip

    Edito para añadir: Leyendo más cuidadosamente el hilo antes mencionado, parece ser que tienen un problema con el "equipo" generador de versiones "nightly". El problema no es tanto la versión del programita que maneja los diccionarios sino del equipo que "crea" ese programita para que nuestros kobo lo "entiendan".
    Cita Iniciado por aquí en teoría se corregía el problema
    Oct 20, 2017
    Bump base (sdcv 0.5.2; fix *buntu 17.10 build & segfault)
    Código:
    1,1M oct 16 16:03 sdcv_0001
    1,1M oct 18 21:19 sdcv_0002
    593K oct 21 15:25 sdcv_0003
    195K ago 21 15:58 sdcv_1152
    195K sep 16 06:08 sdcv_1218
    195K oct 17 06:14 sdcv_1348
    195K oct 19 06:11 sdcv_1351
    669K oct 21 06:13 sdcv_1358
    673K oct 22 06:09 sdcv_1364
    673K oct 23 06:08 sdcv_1370
    673K oct 24 06:27 sdcv_1373
    673K oct 25 06:10 sdcv_1376
    sdcv_0001:                                    ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, BuildID[sha1]=873e2891909081f9e2052a8a551de4e4404915cf, stripped
    sdcv_0002:                                    ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, BuildID[sha1]=06fb8854f803cfaf66dcbdf268098d0dfa8c9ef9, stripped
    sdcv_0003:                                    ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, BuildID[sha1]=9e6f9aee23c7cf4e240e1450fcd16a3060cf5fa4, stripped
    sdcv_1152:                                    ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, stripped
    sdcv_1218:                                    ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, stripped
    sdcv_1348:                                    ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, stripped
    sdcv_1351:                                    ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, stripped
    sdcv_1358:                                    ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, stripped
    sdcv_1364:                                    ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, stripped
    sdcv_1370:                                    ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, stripped
    sdcv_1373:                                    ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, stripped
    sdcv_1376:                                    ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, stripped
    Como veis existe un cambio en el tamaño del archivo sdcv generado automáticamente con cada versión "nightly" a partir del 21 de octubre, entonces los cambios se están aplicando pero aún así fallan en vuestros dispositivos.
    Cita Iniciado por usuario en ese hilo
    sdcv still segfaults on v2015.11-1358-ge0bc0a1.
    sdcv-arm-linux-gnueabihf-2017-10-18.zip does work.
    -sdcv-0.4-built-on-debian-stretch.zip
    ...
    -Yep, this one does work
    En resumen, hasta que se resuelva el problema tendréis que manualmente parchear con una de esas versiones que ha dejado disponibles Frenzie. Eso salvo que a mayores, no se esté liando la cosa también por el uso de fmon...aunque espero que no
    Última edición por Raven; 25/10/2017 a las 11:26

  8. El Siguiente Usuario Agradeció a Raven Por Este Mensaje:


  9. #16
    Veteran@ en el foro
    Avatar de surquizu

    Fecha de Ingreso
    05/jun/2008
    Ubicación
    Zaragoza
    Mensajes
    3.913
    Sexo
    Sexo usuari@
    Lector
    PRS-505, kobo AuraHD. kobo AuraH2O, kobo GloHD, kobo aura ONE

    Re: Ayuda instalación Koreader

    PERFECTO!!!!!!

    Parcheando manualmente con el binario del primer enlace ya me funcionan los diccionarios. Gracias.

  10. #17
    Jovencit@ en el foro
    Avatar de danielr

    Fecha de Ingreso
    25/abr/2017
    Ubicación
    Mar del Plata
    Mensajes
    24
    Sexo
    Sexo usuari@
    Lector
    Kobo Aura One

    Re: Ayuda instalación Koreader

    Muchas gracias Raven y Surquizu! Acabo de descargar el primer archivo del último comentario de Raven y lo extraje. Lo copié en la carpeta Koreader que está dentro de la carpeta .kobo del lector reemplazando el existente y FUNCIONÓ!

  11. #18
    Veteran@ en el foro
    Avatar de surquizu

    Fecha de Ingreso
    05/jun/2008
    Ubicación
    Zaragoza
    Mensajes
    3.913
    Sexo
    Sexo usuari@
    Lector
    PRS-505, kobo AuraHD. kobo AuraH2O, kobo GloHD, kobo aura ONE

    Re: Ayuda instalación Koreader

    Por si interesa a alguien. en mi web he subido ya una versión de koreader parcheada para su instalación y también he parcheado el koreader del megaparche.

  12. Los Siguientes 2 Usuarios Agradecieron a surquizu por Este Mensaje:


  13. #19
    Jovencit@ en el foro
    Avatar de Raven

    Fecha de Ingreso
    14/jul/2017
    Mensajes
    13
    Lector
    Kobo

    Re: Ayuda instalación Koreader

    Cita Iniciado por surquizu Ver Mensaje
    Por si interesa a alguien. en mi web he subido ya una versión de koreader parcheada para su instalación y también he parcheado el koreader del megaparche.
    Bueno, por fin! Ahora sólo queda esperar que arreglen las "nightly's"...
    Por cierto, para tu web, el megaparche, etc, usa mejor la 2ª versión.
    Última edición por Raven; 25/10/2017 a las 23:41

Temas Similares

  1. Tuto koreader
    Por mangue en el foro Foro general
    Respuestas: 11
    Último Mensaje: 27/09/2017, 13:58
  2. Coolreader y Koreader
    Por Antoga en el foro Kobo
    Respuestas: 9
    Último Mensaje: 20/06/2016, 20:37
  3. Koreader en Kindle Paperwhite 2
    Por 0omme en el foro Amazon Kindle
    Respuestas: 0
    Último Mensaje: 21/07/2015, 22:39
  4. koreader para aura hd
    Por nikitas en el foro Kobo
    Respuestas: 2
    Último Mensaje: 18/04/2014, 17:21
  5. Ayuda en la instalación de Doukan
    Por Muza en el foro Amazon Kindle
    Respuestas: 11
    Último Mensaje: 10/02/2011, 19:14

Permisos de Publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •